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Using the Brightness and Contrast Control

This Reference Guide provides information and procedures for the 

Brightness and Contrast Control.

Kodak provides a set of default color tables with the scanner. These 

tables are bundled and installed with the Scan Validation Tool (SVT). 

A color table is a file that can be downloaded to the scanner which 

contains the information required for the scanner to output the desired 

representation of your color document.

If the default color tables do not meet your specific needs, this tool may 

be used to create your own custom color table. This custom color table 

can then be downloaded to the scanner and used in production.

The color table to be used for front and rear images are set 

independently. When scanning, only one color table can be applied to 

each image (front or back). You can use the same color table for both 

the front and the back, or use one color table for the front and one color 

table for the back.

Use the Scan Validation Tool or your own application to download a 

color table to the scanner. 

For more information regarding the Brightness and Contrast Control, 

see Appendix A, Color Concepts. 

IMPORTANT:

• The Brightness and Contrast Control is not color management 
software. The output from the Brightness and Contrast Control 
cannot be used to modify monitors or printers. It is only intended to 
modify the color image as produced by the scanner.

• Images created using a custom color table created using a specific 
monitor may appear differently when viewed or printed on other 
monitors or printers. 

• Images used in this Reference Guide are for concept purposes only 
and do not represent the expected image quality.

• Creation, use and management of any custom color table is your 
responsibility. Kodak provides no support beyond verifying scanner 
functionality using Kodak default color tables.
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Before you begin Before using the Brightness and Contrast Control, it is highly 

recommended that you review the information below.

• The Kodak Scan Validation Tool must be installed. This installation 

includes the TWAIN Datasource and the Kodak default color tables. 

Both the Scan Validation Tool and the TWAIN Datasource are 

required to run the Brightness and Contrast Control. 

• Be sure your scanner is in good working order, cleaned and 

calibrated. Refer to your User’s Guide for maintenance procedures.

• Verify that your scanner is capable of receiving custom color tables 

created using the Brightness and Contrast Control. If not, you should 

select the appropriate table from the default color tables provided by 

Kodak for your scanner. You cannot use the Brightness and 
Contrast Control to modify the default color tables. See the chart 

below to determine if your scanner has this functionality. 

• Before you create a custom color table, it is recommended that you 

scan a representative group of documents and run these documents 

with each of the Kodak default color tables. Analyze these images to 

determine if any of the default color tables meet your needs. If not, 

you may want to choose the color table which is closest to meeting 

your needs. This default color table would be a good table to use as a 

starting point to create your custom color table. 

• When scanning color images, the following settings, in addition to 

color tables, will effect perceived image quality, resolution, color 

sharpening, JPEG compression (Good, Better, Best). Do not change 

the value of these settings when comparing color image results using 

the Kodak default color tables. 

• When using Brightness and Contrast Control to create your own color 

tables, be sure to select the same resolution (DPI) you used when 

evaluating the sample images with the Kodak default color tables. 

Resolution is selected using the DPI option from the File menu.

Scanners Serial 

Number

Minimum 

Firmware 

Version

Upgrade Kit

Kodak i800 Series 

Scanners

12273100 and 

higher

2.0.11 Image Processing 

Upgrade Kit / for Kodak 

i800 Series Scanners 

(for serial numbers 

below 12273100)

CAT No. 106 7974

Kodak i1860 Scanner

Kodak i600, i200, i100 

Series Scanners

all Not applicable

Kodak i30 and i40 

Scanners

all Not applicable
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Supporting 

documentation

Kodak i800 Series Scanners

• Image Processing Guide for Kodak i800 Series Scanners, A-61510

• Installation Planning Guide for Kodak i800 Series Scanners, A-61176

• User’s Guide for Kodak i800 Series Scanners, A-61169

Kodak i1860 Scanner

• Image Processing Guide for the Kodak i1860 Scanner, A-61580

• Installation Planning Guide for the Kodak i1860 Scanner, A-61578

• User’s Guide for the Kodak i1860 Scanner, A-61555

Kodak i600 Series Scanners

• Image Processing Guide for Kodak i600 Series Scanners, A-61504

• User’s Guide for Kodak i600 Series Scanners, A-61500

• Quick Tips Guide for Kodak i600 Series Scanners, A-61501

Kodak i200 Series Scanners

• User’s Guide for the Kodak i200 Series Scanners, A-61167

Kodak i100 Series Scanners

• User’s Guide for the Kodak i100 Series Scanners, A-61514

• Image Processing Guide for Kodak i100 Series Scanners, A-61517

• Quick Tips Guide for Kodak i100 Series Scanners, A-61515

Kodak i30 and i40 Scanners

• User’s Guide for the Kodak i30 and i40 Scanners, A-61512

• Quick Tips Guide for Kodak i30 and i40  Scanners, A-61526

System requirements The PC which will be used to scan images must meet the system 

requirements for the scanner as documented in the Installation 

Planning Guide or User’s Guide for your scanner.

• Operating systems — Windows 98SE, Windows Me, Windows 

2000, Windows XP, Windows NT (for Kodak i800 Series Scanners 

only)

• TWAIN Datasource

Installation 

procedures

To install:

• Be sure you are logged into an account with ADMIN privileges.

• Insert the CD in the CD drive.

- If you have Auto-run enabled, the installation will begin 

automatically.

- If not, navigate to the setup.exe file on the CD to launch the 

installation.
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The main window Following is a description of the menu options on the Brightness and 

Contrast Control main window. See the section entitled, “Using the 

Brightness and Contrast Control” for procedures on how to use this 

software.

File menu The File menu provides the following options:

Open Image — displays the Open Image File dialog box, which allows 

you to open a previously saved uncorrected image from this 

application. Only TIFF files can be opened with this application.

Save Uncorrected Image — displays the Save Image File dialog box, 

which allows you to save the uncorrected image to disk as a color TIFF 

file with a .tif extension. When Save Uncorrected Image is selected, it 

saves the image which was captured using the Acquire option. This 

image represents an image with the null color table.

Save Corrected Image — displays the Save Image File dialog box, 

which allows you to save the corrected image to disk as a color TIFF or 

JPEG file. When Save Corrected Image is selected, it saves the image 

that is displayed on the right-side of the main window. This image 

represents what the scanner will produce when using any color table 

created with this image.

Acquire — used to scan and capture the starting null table image. 

Select TWAIN Source — displays the Select Source dialog box which 

allows you to choose the TWAIN Source for the scanner you will be 

using.

DPI — allows you to select the resolution for the color image you will 

acquire from the scanner.

Exit — closes the application.
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View menu The View menu provides the following options:

Zoom 1/4 — displays the image at one quarter of the original size.

Zoom 1/2 — displays the image at one half of the original size.

Zoom 1:1 — displays the image at the original size.

Zoom 2:1 — displays the image at twice the original size.

Zoom 4:1 — displays the image at four times the original size.

Toolbar — displays/hides the toolbar. The toolbar buttons correspond 

to commonly used menu options.

Icon Description

Open Image — displays the Open Image File dialog box, which 

allows you to open a previously saved image from this 

application.

Load Color Tables — displays the Open Color Table dialog box, 

which allows you to open the color table you want to use. 

Save Color Tables — displays the Save Color Table dialog box, 

which allows you to save the custom color table which, when 

used, will render an image that matches the image currently 

displayed on the right-side of the main window. The color table 

will be saved with an .ekct extension.

Save Uncorrected Image — displays the Save Image File 

dialog box, which allows you to save the uncorrected image to 

disk as a color TIFF file with a .tif extension. 

Zoom 1/4 — displays the image at one quarter of the original 

size.

Zoom 1/2 — displays the image at one half of the original size.

Zoom 1:1 — displays the image at the original size.
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Status bar — displays the X and Y coordinates of the current location 

within the displayed image, the RGB values, the name of the color table 

currently being applied to the original image (displayed on the left side 

of the main window) and the scanner used to acquire the starting 

original. 

Using RGB values will help you to compare and analyze images. 

Icon Description

Zoom 2:1 — displays the image at twice the original size.

Zoom 4:1 — displays the image at four times the original size.

Brightness/Contrast Tool — displays the Brightness and 

Contrast dialog box which allows you to adjust the brightness 

and contrast values while comparing the original image (on the 

left) to the result (on the right).

Help — displays the Brightness and Contrast Control software 

version number.
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Color Tables menu The Color Tables menu provides the following options:

Null — when selected, will load the Null color table into the Brightness 

and Contrast Control. 

Load... — displays the Open Color Table dialog box which allows you 

to select the color table you want to use.

Save... — displays the Save Color Table dialog box, which allows you 

to save the custom color table which, when used, will render an image 

that matches the image currently displayed on the right-side of the 

Brightness and Contrast Control main window. The color table will be 

saved with an .ekct extension. 

Install to TWAIN... — places a copy of the custom color table into the 

default directory used by the TWAIN Datasource 

(C:\“windows”\twain_32\kodak\kds_“scanner”\ColorTables\”scanner”).

Install to ISIS... — places a copy of the custom color table into the 

default directory used by the ISIS Device Driver 

(C:\”windows”\pixtran\ColorTbl\“scanner”).

Delete... — displays the Delete Color Table dialog box which allows 

you to delete custom color tables from your hard drive.

Delete from TWAIN... — deletes the custom color table from the 

default directory used by the TWAIN Datasource 

(C:\“windows”\twain_32\kodak\kds_“scanner”\ColorTables\”scanner”).

Delete from ISIS... — deletes the custom color table from the default 

directory used by the ISIS Device Driver 

(C:\”windows”\pixtran\ColorTbl\“scanner”).

NOTE: Using any Delete option permanently deletes the selected file 

from your hard drive and cannot be retrieved from the recycle 

bin. Once deleted, this file cannot be restored using this tool. 
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Tools menu The Tools menu provides the following options:

Brightness and Contrast — displays the Brightness and Contrast 

dialog box which allows you to adjust the brightness and contrast 

values while comparing the original image on the left side of the 

Brightness and Contrast Control main window to the resultant image on 

the right side.

Help menu Displays the Brightness and Contrast Control software version number.
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Creating a custom 

color table

After you have reviewed the “Before you begin” section, you will be 

ready to start using the Brightness and Contrast Control.

Using a Kodak default 
color table as a starting 
point

Before you create a custom color table, it is recommended that you 

scan a representative group of documents and run this group of 

documents with each of the Kodak default color tables. Analyze these 

images to determine if any of the default color tables meet your needs. 

If not, you may want to choose the color table which is closest to 

meeting your needs. This default color table would be a good table to 

use as a starting point to create your custom color table. 

1. Open the Brightness and Contrast Control application. The main 

window will be displayed.

2. Select File>Select TWAIN Source. The Select Source dialog box 

will be displayed. 

3. Highlight the desired source and click Select.

4. From the File menu select File>DPI and choose the resolution 

which you will use when capturing color images in your production 

environment. 
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5. From the Brightness and Contrast Control main window, select 

File>Acquire. 

6. Feed the document you have selected to use as a starting point to 

create your custom color table. When completed, the uncorrected 

scanned image will appear in both the left and right sides of the 

main window.

NOTE: This image may be saved and used for the creation of 

future color tables.

7. Select Color Tables>Load. The Open Color Table dialog box is 

displayed.

8. Highlight the color table that you determined comes closest to 

matching your color requirements, and click Open. The color table 

you selected will be applied to the images displayed in both the left 

and right window.

9. Select Tools>Brightness and Contrast. The Brightness and 

Contrast dialog box will be displayed.

10.Adjust the Brightness and Contrast slider bars until you are satisfied 

with the color image quality of the image that is displayed on the 

right side of the main window. As you move the Brightness and 

Contrast slider bars, the changes in the brightness and contrast will 

be visible on the right side of the window when you release the 

mouse button. Optionally, you may enter a value in the Brightness 

or Contrast fields. Acceptable values are: -50 to +50.

11. Click OK when the image displayed on the right side of the main 

window is acceptable.

NOTE: Selecting Cancel will undo any changes and restores the image 

on the right side to match the original image (on the left side).
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12.Select Color Tables>Save. The Save Color Table dialog box will be 

displayed:

13.Enter a color table name in the Filename field and click Save. This 

custom color table will be saved in the directory shown in the Save 

Color Table dialog box and is available for download to your scanner 

to be used in production.

NOTE: If you change the default directory path which appears 

in the Save Color Table dialog box, you may have to 

navigate to find this table during production. The scanner 

TWAIN device driver uses this directory by default 

(C:\“windows”\twain_32\kodak\kds_“scanner”\ColorTables). 

For ISIS applications, color tables should be placed in the 

ISIS default directory 

(C:\"windows"\pixtran\ColorTbl\“scanner”). You can navigate 

to this directory using the Save Color Table dialog box or 

copy files manually after they have been saved, or use the 

Install to TWAIN or Install to ISIS options.

14.Select File>Save Corrected Image. The Save Image File dialog 

box will be displayed. This allows you to save the image on the right 

side of the main window to your hard drive for future reference when 

verifying your custom color table. 
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Using an Uncorrected 
image as a starting point

1. Open the Brightness and Contrast Control application. The main 

window will be displayed.

2. Select File>Select TWAIN Source. The Select Source dialog box 

will be displayed. 

3. Highlight the desired source and click Select.

4. From the File menu select File>DPI and choose the resolution 

which you will use when capturing color images in your production 

environment. 

5. Select File>Acquire. 

6. Feed the document you have selected to use as a starting point to 

create your custom color table. When completed, the uncorrected 

scanned image will appear in both the left and right sides of the 

Brightness and Contrast Control main window.

7. Select Tools>Brightness and Contrast. The Brightness and 

Contrast dialog box will be displayed.

8. Adjust the Brightness and Contrast slider bars until you are satisfied 

with the color image quality of the image that is displayed on the 

right side of the main window. As you move the Brightness and 

Contrast slider bars, the changes in the brightness and contrast will 

be visible on the right side of the window when you release the 

mouse button. Optionally, you may enter a value in the Brightness 

or Contrast fields. Acceptable values are: -50 to +50.

9. Click OK when the image displayed on the right side of the 

Brightness and Contrast Control window is acceptable.

NOTE: Selecting Cancel will undo any changes and restores the 

image on the right side of the main window to match the 

original image (on the left side).
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10.Select Color Tables>Save. The Save Color Table dialog box will be 

displayed:

11. Enter a color table name in the Filename field and click Save. This 

custom color table will be saved in the directory shown in the Save 

Color Table dialog box and is available for download to your scanner 

to be used in production.

NOTE: If you change the default directory path which appears 

in the Save Color Table dialog box, you may have to 

navigate to find this table during production. The scanner 

TWAIN device driver uses this directory by default 

(C:\“windows”\twain_32\kodak\kds_“scanner”\ColorTables). 

For ISIS applications, color tables should be placed in the 

ISIS default directory 

(C:\"windows"\pixtran\ColorTbl\“scanner”). You can navigate 

to this directory using the Save Color Table dialog box or 

copy files manually after they have been saved, or use the 

Install to TWAIN or Install to ISIS options.

12.Select File>Save Corrected Image. The Save Image File dialog 

box will be displayed. This allows you to save the image on the right 

side of the main window to your hard drive for future reference when 

verifying your custom color table. 

Saving the original 
image

1. Open the Brightness and Contrast Control application. The main 

window will be displayed.

2. Select File>Select TWAIN Source. The Select Source dialog box 

will be displayed. 
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3. Highlight the desired source and click Select.

4. From the File menu select File>DPI and choose the resolution 

which you will use when capturing color images in your production 

environment. 

5. From the Brightness and Contrast Control main window, select 

File>Acquire. 

6. Feed the document you have selected to use as a starting point to 

create your custom color table. When completed, the uncorrected 

scanned image will appear in both the left and right sides of the 

main window.

7. Select File>Save Uncorrected Image. The Save Image File dialog 

box will be displayed:

NOTE: This file may now be used as a starting point for any future 

activities with the Brightness and Contrast Control. For 

example, you may use the File>Open Image option to work 

with these files off-line when a scanner is not available. 



A-61506    September 2006 15

Using a previously 
captured image as a 
starting point

IMPORTANT: You must use an uncorrected image as your starting 
point for any activity which will result in the creation of a 
custom color table. If you do not choose an uncorrected 
image the following message will be displayed, The 
origin of this image cannot be determined from the 
file! It may not have been originally scanned with 
NULL color tables, and is therefore not a valid image 
for use in this application.

1. Open the Brightness and Contrast Control application. The 

Brightness and Contrast Control main window will be displayed.

2. Select File>Open Image. The Open Image File dialog box will be 

displayed. 

3. Select the desired image file and click Open. The selected image 

will be displayed on both sides of the main window.

4. Select Tools>Brightness and Contrast. The Brightness and 

Contrast dialog box will be displayed.

5. Adjust the Brightness and Contrast slider bars until you are satisfied 

with the color image quality of the image that is displayed on the 

right side of the main window. As you move the Brightness and 

Contrast slider bars, the changes in the brightness and contrast will 

be visible on the right side of the window when you release the 

mouse button. Optionally, you may enter a value in the Brightness 

or Contrast fields. Acceptable values are: -50 to +50. 
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6. Click OK when the image displayed on the right side of the 

Brightness and Contrast Control main window is acceptable.

NOTE: Selecting Cancel will undo any changes and restores the 

image on the right side of the Brightness and Contrast 

Control main window to match the original image (on the 

left side).

7. Select Color Tables>Save. The Save Color Table dialog box will be 

displayed:

8. Enter a color table name in the Filename field and click Save. This 

custom color table will be saved in the directory shown in the Save 

Color Table dialog box and is available for download to your scanner 

to be used in production.

NOTE: If you change the default directory path which appears 

in the Save Color Table dialog box, you may have to 

navigate to find this table during production. The scanner 

TWAIN device driver uses this directory by default 

(C:\“windows”\twain_32\kodak\kds_“scanner”\ColorTables). 

For ISIS applications, color tables should be placed in the 

ISIS default directory 

(C:\"windows"\pixtran\ColorTbl\“scanner”). You can navigate 

to this directory using the Save Color Table dialog box or 

copy files manually after they have been saved, or use the 

Install to TWAIN or Install to ISIS options.

9. Select File>Save Corrected Image. The Save Image File dialog 

box will be displayed. This allows you to save the image on the right 

side of the main window to your hard drive for future reference when 

verifying your custom color table. 
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Verifying a custom 

color table using the 

Scan Validation Tool

Following are procedures for verifying a custom color table using the 

Scan Validation Tool. For detailed procedures on using the Scan 

Validation Tool see the Image Processing Guide for Kodak i800 Series 

Scanners, A-61510 or the Image Processing Guide for Kodak i600 

Series Scanners, A-61504.

1. Open the Scan Validation Tool.

NOTE: Be sure Save Images to Files is checked.

2. From the Imaging tab, select the custom color table from the drop 

down list you want to verify.

NOTES:

• When duplex scanning, you must specify the desired table for 

both the front image and rear image. 

• If you have not saved your custom color table in the default 

directory, it will not appear in the drop-down list and you will need 

to go to the Setup tab. Click Download to locate and download 

the desired table.

3. Click OK on the Kodak Scanner Properties dialog box.

4. Scan your representative documents to capture your images.

5. Exit the Scan Validation Tool.

6. Use an image viewer, e.g., Imaging for Windows, to open and 

compare the image files you just captured to the corrected image 

you saved previously when creating your custom color table.
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Deleting a custom 

color table

To delete a custom color table:

1. Open the Brightness and Contrast Control application.

2. Select Color Tables>Delete. The Delete Color Table dialog box will 

be displayed:

3. Select the color table you want to delete and click Delete.

4. The message, Are you sure you want to delete this color table? 
is displayed. Click Delete to confirm the deletion.

NOTES:

• Deleting a color table will permanently remove this file from your hard 

drive and cannot be retrieved from the recycle bin. 

• Kodak default color tables cannot be deleted.
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Glossary Brightness — Brightness and Contrast Control uses a brightness 

scale from -50 (darkest) to +50 (lightest). Changing the Brightness 

value will effect all color pixels in the image uniformly making all colors 

in the entire image darker or lighter according to the values selected.

Contrast — Brightness and Contrast Control uses a contrast scale 

from -50 (subtle) to +50 (sharp). As Contrast values become more 

positive, darks become darker, and lights become lighter in order to 

create as much distinction as possible between lights and darks.

GUI — graphical user interface.

Color Table — a file downloaded to the scanner which contains the 

information required for the scanner to output the desired color. Only 

one table may be resident in the scanner. Multiple tables may be saved 

as files on the host PC. Each scanner family has a unique file format. 

Color tables cannot be shared across scanner platforms. Color tables 

are stored using the file extension .ekct. Kodak provides default color 

tables which are bundled and installed with the Scan Validation Tool. 

For more information about these default tables (a description of each 

and when you would you use it), see the Image Processing Guide for 

your scanner. One or more of the default color tables should meet your 

needs, if not, this tool may be used to create your own custom color 

table. For Kodak service testing purposes a Kodak default color table 

will be used. 

SVT (Scan Validation Tool) — a diagnostic application provided by 

Kodak to test your scanner to verify scanner functionality. For detailed 

information about the SVT, see the Image Processing Guide for your 

scanner.

JPEG — Joint Photographic Experts Group (compressed image 

format).

NULL color table — a table used by the scanner in place of a color 

table which does not modify the raw image data, and therefore, can be 

used to create an uncorrected image. 

RGB — Red, Green, Blue. Brightness and Contrast Control uses 24-bit 

color images. Each pixel in the image has an 8-bit Red value (0 to 255), 

an 8-bit Green value (0 to 255) and an 8-bit Blue value (0 to 255). 

Uncorrected image — a color image created using a NULL color table 

(raw image from the scanner).
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Error messages Following is a listing of error messages that you may encounter when 

using the Brightness and Contrast Control.

Message: The origin of this image cannot be determined from the file. 
If it was not originally scanned with NULL color tables, then it may not 
be a valid image for use in this application.

Description/Action: You tried to open an image that is not a valid file 

for use with the Brightness and Contrast Control. File>Open Image 

can only be used for files created using the File>Save Uncorrected 

Image option. 

Message: This image was originally obtained from a scanner of a type 
different from the one currently selected. It may not be a valid image for 
use in this application. 

Description/Action: Be sure that the image you selected was acquired 

with the same TWAIN Source you are currently using.

Message: Warning: The current scanner type is not known! 
Description/Action: The Brightness and Contrast Control can only be 

used with Kodak scanners. Be sure the TWAIN Source you selected is 

for a Kodak scanner.

Message: You can only save EKCT files with this command! 
Description/Action: When using the option Color Tables>Save, the 

Brightness and Contrast Control will create your custom color table. 

The file extension for these tables must be .ekct in order for use in your 

production application.

Message: Source Manager is already open. 
Description/Action: If you want to change scanners, exit and restart 

the Brightness and Contrast Control then select the desired TWAIN 

Source. You cannot change sources while the Brightness and Contrast 

Control is running.

Message: Unable to load the Source Manager.
Description/Action: Exit and restart the Brightness and Contrast 

Control application. If the error occurs again, open the Scan Validation 

Tool to verify that it is working properly. If it is, call Kodak Service for 

assistance with the Brightness and Contrast Control. If the Scan 

Validation Tool is not working properly, contact Kodak Service for 

assistance with the scanner. 

Message: Unable to find the DSM_Entry point.
Description/Action: Call Kodak Service. 

Message: Source Manager must be opened first.
Description/Action: Prior to using the File>Acquire option, you must 

use File>Select TWAIN Source and choose the scanner.
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Message: There is already an open Source in use.
Description/Action: If you want to change scanners, exit and restart 

the Brightness and Contrast Control then select the desired TWAIN 

Source. You cannot change sources while the Brightness and Contrast 

Control is running.

Message: Unable to open the Source Manager selection dialog box. 
Description/Action: Exit and restart the Brightness and Contrast 

Control application. If the error occurs again, open the Scan Validation 

Tool to verify that it is working properly. If it is, call Kodak Service for 

assistance with the Brightness and Contrast Control. If the Scan 

Validation Tool is not working properly, contact Kodak Service for 

assistance with the scanner. 

Message: Unable to enumerate first TWAIN Data Sources.
Description/Action: Be sure the Kodak Scan Validation Tool is 

installed on the PC where you are currently running the Brightness and 

Contrast Control. 

Message: Unspecified TWAIN error. 
Description/Action: Exit and restart the Brightness and Contrast 

Control application. If the error occurs again, open the Scan Validation 

Tool to verify that it is working properly. If it is, call Kodak Service for 

assistance with the Brightness and Contrast Control. If the Scan 

Validation Tool is not working properly, contact Kodak Service for 

assistance with the scanner. 

Message: Source could not return color table information.
Description/Action: Exit and restart the Brightness and Contrast 

Control application. If the error occurs again, open the Scan Validation 

Tool to verify that it is working properly. If it is, call Kodak Service for 

assistance with the Brightness and Contrast Control. If the Scan 

Validation Tool is not working properly, contact Kodak Service for 

assistance with the scanner. 

Message: Source does not support ICAP_XFERMECH.
Description/Action: The Brightness and Contrast Control can only be 

used with Kodak scanners. Be sure the TWAIN Source you selected is 

for a Kodak scanner.

Message: ICAP_XFERMECH not support NATIVE transfers. 
Description/Action: The Brightness and Contrast Control can only be 

used with Kodak scanners. Be sure the TWAIN Source you selected is 

for a Kodak scanner.

Message: Failed to set ICAP_XFERMECH.
Description/Action: The Brightness and Contrast Control can only be 

used with Kodak scanners. Be sure the TWAIN Source you selected is 

for a Kodak scanner.
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Message: Source is in wrong state for enabling.
Description/Action: Exit and restart the Brightness and Contrast 

Control application. If the error occurs again, open the Scan Validation 

Tool to verify that it is working properly. If it is, call Kodak Service for 

assistance with the Brightness and Contrast Control. If the Scan 

Validation Tool is not working properly, contact Kodak Service for 

assistance with the scanner. 

Message: Source failed to enable. 
Description/Action: Exit and restart the Brightness and Contrast 

Control application. If the error occurs again, open the Scan Validation 

Tool to verify that it is working properly. If it is, call Kodak Service for 

assistance with the Brightness and Contrast Control. If the Scan 

Validation Tool is not working properly, contact Kodak Service for 

assistance with the scanner. 

Message: Unsupported scanner. 
Description/Action: The Brightness and Contrast Control can only be 

used with Kodak scanners. Be sure the TWAIN Source you selected is 

for a Kodak scanner.

Message: Unsupported or non-existent scanner.
Description/Action: The Brightness and Contrast Control can only be 

used with Kodak scanners. Be sure the TWAIN Source you selected is 

for a Kodak scanner.

Message: Cannot open specified Color Table file. 
Description/Action: There may be a problem with the specified color 

table. If the table selected is a default Kodak color table, reinstall the 

Scan Validation Tool. If this is a custom color table, you may need to 

recreate the color table unless you are able to restore from a backup 

copy.

Message: The specified color table file is not writable.
Description/Action: The Brightness and Contrast Control was unable 

to open the specified color table file for output. This error may occur if 

the color table is an original distribution color table (e.g., photo.ekct) 

and the Brightness and Contrast Control will not overwrite it. It could 

also mean that there is a bad file name, the file is write-protected or the 

disc is full. 

Message: The specified color table format is unsupported.
Description/Action: Color tables must have the .ekct extension. Only 

tables provided by Kodak or created with the Brightness and Contrast 

Control are supported.

Message: Incorrect checksum detected in Color Table file.
Description/Action: Color tables must have the .ekct extension. Only 

tables provided by Kodak or created with the Brightness and Contrast 

Control are supported.
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Message: An error occurred while writing the image file. 
Description/Action: Be sure your account has write access to the 

output directory.

Message: Unable to delete the selected color table. 
Description/Action: Be sure your account is authorized to delete color 

tables.

Message: You cannot delete an original distribution color table.
Description/Action: Kodak default color tables cannot be deleted. 

Troubleshooting / 

Problem solving 

Use the information below as a guide to check possible solutions to 

problems you may encounter when using the Brightness and Contrast 

Control.

Brightness and Contrast Control will not run
• Check to be sure you have Administrative privileges. If you do, be 

sure the Brightness and Contrast Control was installed using an 

Admin account. If not, contact your System Administrator.

Cannot scan
• Exit the Brightness and Contrast Control software and run the Kodak 

Scan Validation Tool to verify that the scanner is in good working 

condition. If the scanner is working correctly and you still cannot scan 

using the Brightness and Contrast Control, verify that the path that 

you are trying to save the image to is correct.

No drivers are displayed in the Select Source dialog box
• Be sure the Scan Validation Tool is installed.

Unable to download a custom color table

• Be sure the scanner is turned on and ready to use (no error condition 

exists). 

• Be sure the table you are attempting to download is compatible with 

your scanner. 

• Run the Scan Validation Tool to be sure that the scanner is in good 

working condition. 

Cannot save a custom color table

• Check the destination path for saved files.

Poor color image quality from the scanner 

• Download and use a Kodak default color table. If the problem 

persists, be sure the scanner is in good working condition. You may 

need to clean the scanner, calibrate it, run the Scan Validation Tool, 

etc. 

If the color image quality improved with the use of a Kodak default 

color table or by cleaning the scanner, etc. do not use the originally 

selected custom color table without adjusting it to meet your color 

quality needs. 
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Appendix A     Color Concepts

What is a color 

image?

A digital color image contains information about a scanned document 

subdivided into many small regions called pixels (picture elements). 

Each pixel is represented as a 24-bit value. These 24 bits are used to 

indicate the amount of red, green and blue for each pixel. Pixels are 

arranged in a matrix to collectively represent the image. Each pixel 

represents a single color, present at that location in the image. 

What is a color table? The color cameras in a scanner typically deliver three channels of data 

to the image processing system, representing the Red, Green, and 

Blue content of the image. 

This raw data can then be fine-tuned to more closely represent the 

original document by mapping raw input colors to the desired output 

colors. This is usually done with a color table. The color table is simply 

a list of input values matched to the desired output colors.

What is the 

Brightness and 

Contrast Control?

The purpose of the Brightness and Contrast Control is to provide a tool 

whereby a user can adapt or develop a custom color table for a Kodak 
Innovation Series Scanner, to suit the needs of a particular application. 

The Brightness and Contrast Control provides a graphical user 

interface which allows the user to preview the effect a color table will 

have on a representative customer image. It can acquire a 

representative image from the Kodak Innovation Series Scanner or 

load it from a file. The utility provides tools which permit creating, 

modifying and saving custom color tables. 
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